
BioCyc (https://biocyc.org/) provides reconstructed metabolic networks for 20,000 sequenced organisms 
and access to 3,085 pathways and 18,786 metabolites.

BioCyc's informatics tools include the following:

• Pathway diagrams with chemical structures 

• Zoomable, organism-specific metabolic network diagrams

• The capability of overlaying user-obtained OMICS study results (for example, fold change, peak area, 
or stable isotope labeling data) onto metabolic pathways

This tutorial shows you how to work with the BioCyc Pathways mapping feature in the 
Thermo Scientific™ Compound Discoverer™ 3.3 service pack 2 (SP2) application. 

To map the biological pathways for the ZDF rat data set, follow these topics in order:

1. Locate the ZDF example files

2. Start the Compound Discoverer application

3. Setup a new user account or request free trial access or purchase a subscription for an existing account

4. Check the computer’s access to the BioCyc database

5. Modify the original ZDF analysis and submit it for partial reprocessing

6. Review the BioCyc mapping results

Compound Discoverer 3.3 SP2 BioCyc Tutorial 

IMPORTANT  To use the BioCyc Pathways mapping feature, you must set up a BioCyc account. To 
select a mouse (organism) database for the ZDF rats sample set that you use in this tutorial, you must 
set up a BioCyc account and a BioCyc subscription as described in the topic “Setup a new user 
account or request free trial access or purchase a subscription for an existing account” on page 5. 

The first time you set up a BioCyc account, you are granted free unlimited access to all the BioCyc 
databases for a brief demonstration period. If you have an existing BioCyc account, you can request 
free access to all the BioCyc databases for a 30-day trial period. To continue your unlimited access to 
all the BioCyc pathway databases when this free trial period expires, you must purchase a subscription.

Note  If you are using the Compound Discoverer 3.3 SP1 application instead of the Compound 
Discoverer 3.3 SP2 application, you must install the following configuration file:

BioCycService.config

For information about downloading this file from the LSMS Software Download and Licensing portal 
and installing this file on your data system computer, see the following topic: “Using the BioCyc 
Pathway Mapping feature in Compound Discoverer 3.3 SP1” on page 28. After you install the 
configuration file, you can begin this tutorial at “Copy the ZDF example files to your data processing 
computer” on page 3.
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Locate the
ZDF example

files

In this tutorial you use the same ZDF example files that Thermo Fisher Scientific originally provided for 
the metabolomics tutorial. If you already have these files on a local hard drive on your data processing 
computer, skip this topic and go to “Start the Compound Discoverer application” on page 4. 

To copy the example files to a local hard drive on your data processing computer, do one of the following:

• If you do not already have the example ZDF files on the local hard drive of your data processing 
computer, and you do not have the key-shaped USB drive that was provided in the Compound 
Discoverer 3.3 software media kit, do the following:

a. Follow the instructions in “Download the ZDF example files.”  

b. Follow the instructions in “Copy the ZDF example files to your data processing computer” on 
page 3.

• If you have the key-shaped USB drive from the Compound Discoverer 3.3 software media kit, go to 
“Copy the ZDF example files to your data processing computer” on page 3.

Download the
ZDF example

files

If you do not already have the ZDF example files on your data processing computer and you do not have 
the original key-shaped USB drive that was provided in the Compound Discoverer 3.3 software media kit, 
follow this procedure to download these files.

To download the example ZDF files

1. Go to the following URL: thermo.flexnetoperations.com

The LSMS Software Download and Licensing Portal website opens.

2. Log in.

3. Under Software & Services at the left, click the Product List link.

4. On the Product List page, click the Application - Compound Discoverer link.

5. On the Product Information page, click the Compound Discoverer 3.3 SP2 link. 

The Product Download page for the Compound Discoverer 3.3 SP2 application opens. See Figure 1 
on page 3. This page contains the compressed folders with the files for the tutorials provided with the 
application.

Software & Services
Product List
Product Search
Order History

Application - Xcalibur
Application - Proteome Discoverer
Application - Compound Discoverer
Application - ProSightPD
Application - TraceFinder
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Figure 1. Product Download page for the Compound Discoverer 3.3 SP2 application

6. Download the ZDF example files by clicking  to the left of the CD 3.3 SP2 Example 
Metabolomics Study-ZDF. 

These items download to the Downloads folder on your data processing computer.

Copy the ZDF
example files

to your data
processing

computer

For optimal performance of the Compound Discoverer application, store study files (.cdStudy) and result 
files (.cdResult) on the local hard drive of your data processing computer. 

To copy the example files for this analysis to your data processing computer

1. Locate the files on the key-shaped USB flash drive that was provided in the software media kit or 
download the example files from the LSMS Software Download and Licensing Portal website as 
described in “Download the ZDF example files” on page 2.

The example files for this tutorial are in the following folder on the USB flash drive:

Example Studies\LC\Metabolomics\ZDF 

2. If you downloaded the files, extract the files from the CD 3.3 SP2 Example Data Metabolomics 
Study-ZDF.zip compressed folder and copy the CD 3.3 SP2 Example Data Metabolomics 
Study-ZDF folder to a local hard drive on your data processing computer. 

The ZDF folder contains the following files: eight Xcalibur raw data files, one Compound Discoverer 
study file (.cdStudy), and one Compound Discoverer result file (.cdResult).

The software you are about to download is subject to export control laws and regulations. By downloading this software, you agree that 
you will not knowingly, without prior written authorization from the competent government authorities, export or reexport - directly or 
indirectly - any software downloaded from this website to any prohibited destination, end-user, or end-use.

Product Download

Compound Discoverer 3.3 SP2

Compound Discoverer 3.3 SP2 Free Upgrade Installation 
Instructions

CD 3.3 SP2 Example Data Metabolomics Study-ZDF.zip

CD 3.3 SP2 Example Data Stable Isotope Labeling 
Study.zip

CD 3.3 SP2 Example GC Studies.zip

Compound Discoverer 3.3 SP2.zip

Compound Discoverer 3.3 SP2 Free Upgrade Installation 
lnstructions.pdf

Compound Discoverer 3.3 SP2 Release Notes.pdf

3.3 GB

2 GB

3 GB

5.7 GB

808.8 KB

1.1 MB

Download Selected Files

6 Files

File Description File Size

Download Help

File Name

CD 3.3 SP2 Example Data Metabolomics Study-ZDF

CD 3.3 SP2 Example Data Stable Isotope Labeling Study

CD 3.3 SP2 Example GC Studies 

Compound Discoverer 3.3 SP2 Release Notes

Compound Discoverer 3.3 SP2

?

Tip  For most analyses, you can store the input files (Xcalibur raw data files) for an analysis on a local 
hard drive, an external hard drive, or a network drive, without sacrificing performance. For this 
tutorial, keep all the files together in the ZDF folder. If you change the relative location of the raw 
data files, you must resolve the location of the input files for the analysis. For more information, refer 
to the “Resolve the location of the input files in a study” Help topic. 
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Start the
Compound
Discoverer
application

This tutorial describes how to use review the BioCyc pathway mapping results from an analysis run on a 
data processing computer with the Compound Discoverer 3.3 SP2 application1. The Compound 
Discoverer 3.3 SP2 application is compatible with the Windows™ 10 and Windows 11 operating systems.

To start the Compound Discoverer 3.3 SP2 application

Do one of the following:

• On the Windows 10 taskbar, click Start . Then, choose Thermo Compound Discoverer 3.3 
> Compound Discoverer 3.3 from the Start menu.

• On the Windows 11 taskbar, click Start . Then, click the Compound Discoverer 3.3 icon in 
the Pinned apps section or in the All Apps section of the Start menu, open the Thermo 
Compound Discoverer 3.3 folder, and choose Compound Discoverer 3.3.

–or–

• From the computer desktop, double-click the Compound Discoverer icon, .

The application opens to the Start Page. 

Figure 2. Compound Discoverer window (prior to creating any studies or running any analyses)

1 After you install the required configuration file, you can also follow this tutorial for the Compound Discoverer 3.3 SP1 application.

No. Description No. Description

1 Application menu bar 2 Study toolbar
3 Data review toolbar 4 Reporting toolbar

1

2

3

4
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Setup a new
user account

or request free
trial access or

purchase a
subscription

for an existing
account

You must have a user account to use the BioCyc pathways mapping feature in the Compound Discoverer 
application. To access all the BioCyc databases, you must also have an organization subscription, an 
individual subscription, or your free 30-day trial period of full access must not have expired. 

To create a user account, your data processing computer must have Internet access. The first time you set 
up a user account, with or without a subscription, you will have unlimited access to all the BioCyc 
databases for a 30-day trial period. However, if you do not have a paid subscription, you will lose access to 
all the BioCyc databases, except for the EcoCyc and MetaCyc databases, when your free trial period 
expires.

If you have an existing user account but no subscription, you can request 30 days of free access to all the 
BioCyc databases.

To create and activate your user account and purchase a subscription or to request a 30-day trial period of 
free access to all the BioCyc databases, follow these topics:

1. Open the BioCyc User Login view

2. Do the following as needed:

• Create a new user account

• Purchase a subscription or request a free 30-day trial period

3. Enter, test, and save your BioCyc account information

Open the
BioCyc User

Login view

You must validate your BioCyc user account from the BioCyc User Login view of the Compound 
Discoverer application. 

To open the BioCyc User Login view

1. From the Compound Discoverer 3.3 SP2 menu bar, choose Help > Configuration.

2. In the navigation pane on the Configuration page, under Miscellaneous Settings, choose BioCyc 
User Login. 

The BioCyc User Login view appears at the right with the following information:

• The Organization Subscription area displays the status of your organization subscription, if you 
have one. 

• The User Subscription area displays your email address and the remaining time on your trial 
access period or individual subscription. See Figure 4 on page 8.

• The Subscription Information area includes instructions for creating a new account, purchasing a 
subscription, and requesting a free 30-day trial period for an existing account. See Figure 3.
5



Figure 3. BioCyc User Login view with no user account information

3. Review the current user account and subscription information in the BioCyc User Login view:

• Review the information in the Organization Subscription area: 

 If you have an organization subscription, the Organization Subscription area displays the 
organization name in green. 

 If you do not have an organization subscription, the Organization Subscription area displays the 
following text in red: No Valid Subscription Found. 

• Review the information for your user account in the User Subscription area:

 If you have already set up a BioCyc user account—that is, you have entered and tested your 
credentials (email address and password) and saved the settings—the Username box displays 
your email address. 

 If you do not have an individual subscription or free trial access to all the BioCyc databases, the 
following text appears in red under User Subscription: 

No Valid Subscription Found. 

Note  You do not need an organization subscription to use the BioCyc pathways mapping 
feature. 
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Create a new
user account

You must have a user account to use the BioCyc pathways mapping feature in the Compound Discoverer 
application. To access all the BioCyc databases, you must have one of the following: an organization 
subscription, an individual subscription, or your 30-day free trial access must not have expired. 

To create a new BioCyc user account

1. Click the following link in the BioCyc User Login view: 

https://biocyc.org/new-account.shtml

The BioCyc website opens to the Create Free Account page.

2. Sign up for your account.

3. To activate your new BioCyc account, go to “Enter, test, and save your BioCyc account information.”  

Purchase a
subscription or

request a free
30-day trial

period

To purchase a subscription or request a free 30-day trial period for an existing account

1. In the BioCyc User Login view, click the following link:

https://biocyc.org/thermofisher.shtml

The BioCyc website opens to the Welcome Thermo Fisher Customers page.

2. Do one of the following: 

• To request trial access to all the BioCyc databases, click Request Trial Access, and then follow the 
instructions on the website.

• To purchase an individual subscription, click Individual Subscriptions, and then follow the 
instructions on the website.

• To purchase an organization subscription, click Institutional Subscriptions, and then follow the 
instructions on the website.

Tip  To purchase a subscription, you must be logged in to the BioCyc website. If you are not logged in, 
the following message appears when you click Checkout. Click LOGIN to log in as requested.
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Enter, test, and
save your

BioCyc
account

information

After you set up your user account, test your credentials, and then save your account information.

To enter, test, and save your account information

1. In the User Subscription area of the BioCyc User Login view on the Configuration page, enter your 
user name (email address) and password.

2. Below the Password box, click Test Credentials.

3. At the bottom right of the view, click Save Current Settings. 

Figure 4 shows the information for a user account with 30 days of trial access to all the BioCyc 
databases.

Figure 4. BioCyc User Login view with information for a new user account

Check the
computer’s

access to the
BioCyc

database

To use the processing workflow that you create in this tutorial, your data processing computer must have 
unblocked access to the BioCyc database on the Internet. 

To test the communication to the online BioCyc database

1. From the application menu bar, choose Help > Communication Tests.

2. Click the BioCyc tab, and then click Run Tests. See Figure 5.

IMPORTANT  If you do not click Save Current Settings to save your account information, the 
following issues will occur:

• You will not have a valid user account the next time you restart the Compound Discoverer 
application, and you will have to enter your user account information again.

• The BioCyc communication test will fail.

• If you add the Map to BioCyc Pathways node to a processing workflow template and attempt 
to run an analysis with this template, the analysis will not map the BioCyc pathways.
8



Figure 5. BioCyc page of the Communication Test dialog box

3. If your computer has an Internet connection, but these tests fail, do one of the following:

• If only the Check BioCyc User Credentials test fails, follow the instructions in “Enter, test, and 
save your BioCyc account information” on page 8. 

• If all the tests fail, go to step 4.

4. If all the test fail, do the following:

a. Leave the Communication Test dialog box open.

b. Press the F1 key (or equivalent, for example, Fn+F1) on the computer keyboard .

The Test Communication to the Online Databases Help topic opens. 

c. Click the Troubleshoot Access to the Online Databases link, and then follow the instructions 
in the Help topic to troubleshoot the communication failure. 

Modify the
original ZDF
analysis and
submit it for

partial
reprocessing

The processing workflow for the original analysis that was used to generate the ZDF.cdResult file did not 
include the Map to BioCyc Pathways node. 

Because the Map to BioCyc Pathways node is downstream of the compound detection nodes, you can add 
it to the original processing workflow and partially reprocess the analysis result. Partial reprocessing does 
not trigger an analysis that involves the core compound detection nodes.

To reprocess the original analysis result with an additional downstream workflow node, the Map to 
BioCyc Pathways node, follow these topics:

1. Open the original analysis for the ZDF analysis result

2. Add the Map to BioCyc Pathways node to the processing workflow

3. Submit the modified analysis to the job queue

Note  In the processing workflow for this tutorial, the Input Files, Select Spectra, Align Retention 
Times, Detect Compounds, Group Compounds, and Fill Gaps nodes are core nodes. 
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Open the
original

analysis for the
ZDF analysis

result

In this tutorial, you partially reprocess the example ZDF.cdResult file in the example ZDF.cdStudy file 
after you add the Map to BioCyc Pathways workflow node to the original analysis.

Prerequisites

You have copied the example ZDF files to a local hard drive on your data processing computer. In 
addition, you have done one of the following: 

• Created a new BioCyc user account with temporary free access to all the BioCyc databases

• Requested a 30-day trial period of free access to all the BioCyc databases for an existing account

–or–

• Created a BioCyc user account and purchased a subscription

To open the original analysis for reprocessing

1. From the application menu bar, choose File > Open Study. 

2. Browse to the ZDF.cdStudy file, select it, and click Open.

The study opens to the Analysis Results page of the study. There is only one analysis result in the table 
on this page. Because the analysis result is not selected, the commands in the Analysis Results 
command bar are unavailable. 

3. Select the analysis result, ZDF.cdResult.

The Open Result and Reprocess commands become available. See Figure 6 on page 10.

4. Click Reprocess. 

Figure 6. Analysis Results page of the example ZDF study

The Analysis view opens. The Analysis view consists of the Grouping and Ratios page, the Workflows 
page, and the Analysis pane. See Figure 7.

Note  An analysis includes the processing workflow, the grouping and ratio settings, and the list of raw 
data files used to generate an analysis result.

Note  For an existing analysis, the Analysis view is also known as the analysis editor. See the tooltip 
for the Reprocess command in Figure 8 on page 12.

In the analysis editor, the Grouping and Ratios page, the Workflows page, and the Analysis pane 
contain settings from the previous analysis. The Grouping and Ratios page contains the sample 
groups and ratios, the Workflows page contains the processing workflow, and the Analysis pane 
contains the filename of the previous analysis result and the list of input files for the analysis.
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In the Analysis pane, the Run button is unavailable, the state of the Processing Step is listed as 
Partially Reprocessing, and there is a Caution symbol at the right of the Edit button.

Figure 7. Analysis editor for the ZDF analysis result

Pointing to the Caution symbol displays the following message:
Unchanged workflow. No node chosen for processing.

Add the Map to
BioCyc

Pathways node
to the

processing
workflow

The processing workflow for the example ZDF analysis result did not include the Map to BioCyc 
Pathways node. 

Prerequisites

The analysis editor for the ZDF analysis result (ZDF.cdResult) is open, and the state of the Processing 
Step is Partially Reprocessing. See “Open the original analysis for the ZDF analysis result” on page 10.

To add the Map to BioCyc Pathways node to the processing workflow

1. Click the Workflows tab.

The Workflows page of the Analysis view opens. 

Note  The original processing workflow for the ZDF analysis result was created by modifying the 
following predefined processing workflow template:

Untargeted Metabolomics with Statistics Detect Unknowns with ID using Online Databases and 
mzLogic.cdProcessingWF
11



In the Workflow Tree and Post-Processing Nodes panes on the Workflows page, notice the following 
in Figure 8: 

• All the workflow nodes have lost their distinguishing colors, and the right sides of all the nodes 
have a gray tab. 

• To the left of the Workflow Tree pane, the Workflow Nodes subpage is open. 

Figure 8. Original processing workflow for the ZDF.cdResult file (analysis result)

2. Add the Map to BioCyc Pathways node under Pathway Mapping by dragging it from the Workflow 
Nodes page at the left to the Workflow Tree pane.

After you drop the Map to BioCyc Pathways node in the Workflow Tree pane, the following changes 
occur on the Workflows page (shown in Figure 9):

• In the Workflow Tree pane, the Group Compounds node automatically connects to the Map to 
BioCyc Pathways node and the Map to BioCyc Pathways node automatically connects to the 
Apply mzLogic node. In addition, the Apply mzLogic node and the Assign Compound 
Annotations node are automatically set for reprocessing, as indicated by their yellow 
background color and the green tab on the right side of each node.

• In the Post-Processing Nodes pane, the Differential Analysis node is automatically set for 
reprocessing, as indicated by the green tab on the right side of the node.

• Below the Post-Processing Nodes pane, the Current Workflow Issues table opens.
12



• The exclamation mark at the top-right corner of the Map to BioCyc Pathways node indicates that 
the node has an undefined parameter setting. This undefined parameter setting is described in the 
Current Workflow Issues table.

In the Analysis pane, the Source File box appears below the Result File box. The application 
automatically duplicates the file name of the original result file in the Result File and Source File 
boxes. See Figure 13 on page 16.

Figure 9 shows the modified processing workflow and the Current Workflow Issues table.

Figure 9. Changes to the processing workflow
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3. In the Workflow Tree pane, click the Map to BioCyc Pathways node to select it.

A dashed green border appears around the node and the Map to BioCyc Pathways page opens to the 
left of the Workflow Tree pane. See Figure 10.

Figure 10. Parameters of Map to BioCyc Pathways page

4. On the Map to BioCyc Pathways page, select the database to be searched as follows:

a. Click the box to the right of the BioCyc Database/Organism to be Searched parameter.

A down arrow icon appears.

b. Click the down arrow and wait a few seconds. If nothing happens, click the down arrow again.

The dropdown list of BioCyc pathway databases appears. See Figure 11.

Map to BioCyc
Pathways
14



Figure 11. Parameter of Map to BioCyc Pathways page with a list of BioCyc Pathways to select from

c. Type mouse in the Filter box.

Only four databases remain in the filtered list.

d. Select the checkbox for the Mus Musculus (MOUSE) database.

Figure 12. Mus Musculus (Mouse) database selection

Note  The Map to BioCyc Pathways node performs pathway mapping by using the exact mass, the 
formula, or both for all the detected compounds. After the analysis is completed, you can filter the 
analysis results by various parameters, for example, you can limit the mapping to compounds in 
the Compounds table that the Search mzCloud node identified. See Table 1 on page 28.
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5. Click anywhere outside the list of databases.

The database list closes, the Mus Musculus (Mouse) selection appears in the BioCyc 
Database/Organism to be Searched box, the exclamation mark disappears from the upper-right 
corner of the Map to BioCyc Pathways node, the Current Workflow Issues table below the 
Post-Processing Nodes pane closes, and the Run button in the Analysis pane becomes available.

Submit the
modified

analysis to the
job queue

In this topic, you submit the modified analysis with the Map to BioCyc Pathways node to the job queue 
for partial reprocessing.

Prerequisites

You have added the Map to BioCyc Pathways node to the original processing workflow for the example 
ZDF.cdResult file, and you have selected the Mus Musculus (MOUSE) database for the search. 

To submit the new analysis to the job queue

1. In the Analysis pane, leave the By File checkbox clear. (This is its default state.)

Figure 13. Default settings for the file names in the Result File and Source File boxes

2. In the Result File box, rename the result file for the new analysis that includes the Map to BioCyc 
Pathways node. For example, rename the file ZDF with Mapped BioCyc Pathways.

Figure 14. Analysis set for partial reprocessing

Note  When the By File checkbox is clear, the application creates one result file for the entire set of 
input files. 

Note  The filename in the Source File box is unavailable for editing. If you do not rename the 
ZDF.cdResult file in the Result File box, the application increments the filename to ZDF-(1).
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3. Click Run.

The Job Queue page opens. 

The analysis maps the detected compounds to the BioCyc pathways in the selected database; applies 
mzLogic scoring to the annotations from the ChemSpider node, the Map to Metabolika Pathways 
node, and the Map to BioCyc Pathways node; performs a differential analysis; and assigns the 
compound annotations to the detected compounds.

4. To view the processing messages, click expand  to the left of the job row.
 

Do not close the Job Queue page. When the run is completed, go to the next topic to “Review the BioCyc 
mapping results.” 

Review the
BioCyc

mapping
results

There are two ways to view the results of the BioCyc pathway mapping. You can review all the mapped 
pathways from the main BioCyc Pathways table or you can review the mapped pathways for a compound 
in the main Compounds table by opening the related BioCyc Pathways table for the compound.

To review the pathway mapping results in your reprocessed analysis result, follow these topics:

1. Open the newly reprocessed result file

2. (Optional) Review the default result page layout

3. View the mapped BioCyc pathways for the analysis

4. Display only the compounds identified by a confirmatory spectral match

Open the newly
reprocessed

result file

The Job Queue page lists all the jobs you have run until you remove them from the Job Queue table.

To open the result file when the job is completed

Double-click the job on the Job Queue page. 

Note  During the run, the application generates several warning messages, which you can ignore. 
Warning messages have a yellow background.

Tip  If the Job Queue page is closed, from the menu bar, choose View > Job Queue to open it. 

You can also open a result file from the Analysis Results page of a study, from the File menu, from 
the Start Page, or from the File Explorer directory. 
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(Optional)
Review the

default result
page layout

The factory default layout for a result file includes the following items, as they are numbered in Figure 15 
on page 19:

1. A page tab with the result file name.

2. A Chromatograms view on the top left that is populated with XIC traces (across the input file set) for 
the compound in the first row of the active table. The view automatically zooms in to the start and 
end points of the chromatographic peak for the compound, and the integrated peak areas are shaded.

3. A Mass Spectrum view on the top right that is populated with the MS1 scan (for a preferred ion) that 
is closest to the chromatographic peak apex for the selected compound across the input files. The 
spectrum tree to the left includes the MS1 scans and the fragmentation scans for the preferred ions 
that were acquired within the following time range:

• The chromatographic peak apex for the selected compound ± peak width at half maximum 
(FWHM)

–or–

• The start and end points of the chromatographic peak, as determined by the peak detection 
algorithm

4. A set of tabbed main tables below the two graphical views. For a metabolomics analysis, the 
Compounds table is the active table, and it is sorted by the Area (Max.) column—that is, the first row 
displays the compound with the largest chromatographic peak area (found in one of the input files). 

5. A collapsed area for the related tables below the main tables.

Figure 15 shows the factory default layout of the views and result tables for the ZDF with Mapped BioCyc 
Pathways.cdResult file. 

Note  If the data set does not include data-dependent MS2 scans within the retention time window 
but does include DIA scans within this window, the spectrum tree includes the DIA scans. Your 
Thermo Scientific data-visualization application displays DIA or AIF in the scan headers of 
data-independent scans. The Compound Discoverer application displays DIA for both of these 
scan types.

Note  Because the selected processing workflow includes the Mark Background Compounds node, 
the Compounds tab has a filter icon with a blue check mark ( ).

The compounds that the analysis identified as background compounds are marked as background 
compounds in both the blank and non-blank samples and are hidden from the table.

Note  In Compound Discoverer 3.1 or later, the chromatographic peak area for compounds and 
features is reported in counts × seconds. The chromatographic peak area for a compound in each input 
file is the combined peak area for all its detected preferred ions (features). 
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Figure 15. Default result file layout (with the exception that row 6 instead of row 1 is selected in the 

Compounds table)

1 2 3

45

Note  Clicking the Select Visible Tables icon to the left of the main table tabs opens the Select 
Visible Tables dialog box where you can view a list of main and related tables that are in the result file 
but are currently hidden. See Figure 16.

Clicking the Field Chooser icon  above the row number column opens the Field Chooser dialog 
box for the active table.
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Figure 16. Select Visible Tables dialog box, which shows that the BioCyc Pathways table is visible as a main 

table and as a related table

View the
mapped
BioCyc

pathways for
the analysis

By default, the BioCyc Pathways table is visible as a main table. In addition, it is visible as a related table 
for any compound that you select in the Compounds table. The BioCyc Results table is available only as a 
main table, and by default it is visible. See Figure 16.

Precondition

The reprocessed result file, ZDF with mapped BioCyc pathways, is open, and it is the active document in 
the application window. See “Open the newly reprocessed result file” on page 17.

To view the BioCyc pathways that include compounds detected by the analysis

1. If you have modified the layout for the reprocessed result file, do the following:

a. Choose Window > Reset Layout from the application menu bar. 

b. At the prompt, click Yes.

Tip  To view the related information for a specific compound in the main Compounds table, do the 
following:

1. Select the compound in the main table.

2. Click Show Related Tables.

3. In the related tables pane, open the table of interest by clicking its tab.
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2. (Optional) Close the Chromatogram and Mass Spectrum views by clicking Close  in the 
upper-right corner of each view.

Closing these views provides more space for reviewing the BioCyc pathways.

3. Click the BioCyc Pathways tab in the set of main tables.

4. From the application menu bar, choose View > BioCyc Pathways.

The BioCyc Pathways view appears to the left of the main tables.

5. In the Omics-Overlay dropdown list, select Log2 Fold Change.

6. In the BioCyc Pathways table, select the Purine and Pyrimidine Metabolism pathway (row 5).

All the compounds in the pathway that match compounds in the main Compounds table have a color 
dot that indicates the fold change. The color key for these dots is below the pathways. See Figure 18.

Figure 17. Main BioCyc Pathways table and BioCyc Pathways view with a Log2 Fold Change overlay 

7. To review the pathways in the BioCyc Pathways view, do any of the following:

• Drag the view to a second monitor.

• Use the + and – buttons to enlarge or decrease the size of the pathways.

• Use the mouse wheel to increase or decrease the size of the pathways.

• Point to a compound in a pathway to view more information about the compound.

• Click Print to print the pathways.

Note  In Figure 17, the Checked and Tags table columns are hidden to fit the figure on the page.

Tip  To display the + (increase size), – (decrease size), and print buttons at the left side of the view, 
point anywhere in the pathways area of the view.
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Figure 18. Enlarged BioCyc Pathways view with color-coded compounds and the increase, decrease, and print buttons

View the
mapped

pathways for a
specific

compound in
the Compounds

table

Follow this topic to review the mapped BioCyc pathways for compounds of interest in the main 
Compounds table. 

Prerequisites

The ZDF with BioCyc Mapping.cdResult file is open, and it is the active document in the application 
window. See “Open the newly reprocessed result file” on page 17.

Note  Not every compound in the Compounds table can be found in a metabolic pathway. The 
#BioCyc Pathways column in the Compounds table lists the number of pathways where the analysis 
found each compound, but by default, this column is not visible in the table. To view this column, 
you must enable it.
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To view the mapped BioCyc pathways for a specific compound

1. Add the #BioCyc Pathways column to the Compounds table as follows:

a. Click the Compounds tab to make the Compounds table the active main table.

b. Click the field chooser icon  in the upper-left corner of the table.

The Field Chooser dialog box opens.

c. Select the BioCyc Pathways checkbox.

The BioCyc Pathways column appears to the right of the mzCloud Best Tree Match column and 
to the left of the MS2 column. See Figure 19 on page 23.

d. Close the Field Chooser dialog box.

Figure 19. Default location of the BioCyc Pathways column in the main Compounds table
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2. (Optional) Modify the layout of the columns in the Compounds table to make the BioCyc pathways 
easier to review as follows:

• Right-click the Compounds table and choose Enable Column Fixing. Then, click the pin icons in 
the heading row of the following columns to move them to the left:

i. To move the BioCyc Pathways column to the leftmost column, click the pin icon in its 
heading row.

ii. To move the Name column to the right of the BioCyc Pathways column, click the pin icon in 
its heading row. 

iii. To move the Area Max column to the right of the Name column, click the pin icon in its 
heading row.

• In the BioCyc Pathways column, click the expand icon  to display the BioCyc Pathway names.

Figure 20. Modified layout for the Compounds table

3. In the Compounds table, select Creatine [row 6 when the Compounds table is sorted in descending 
order by Area (Max)].

4. Open the related BioCyc Pathways table for creatine as follows:

a. Click Show Related Tables below the main result tables. See Figure 15 on page 19.

b. In the set of related table tabs for Creatine, click the BioCyc Pathways tab.

c. In the related BioCyc Pathways table, select the Creatine Biosynthesis pathway (row 1). See 
Figure 21 on page 25.
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Figure 21. Creatine biosynthesis pathway selected in the related BioCyc Pathways table for creatine

5. If you closed the BioCyc Pathways view, reopen it by choosing View > BioCyc Pathways in the 
application menu bar. Then, select Log2 Fold Change in the Omics-Overlay dropdown list.

The creatine biosynthesis pathway for the Mus musculus organism appears in the BioCyc Pathways 
view.

6. (Optional) To enlarge the view, drag it to a second monitor.

Figure 22. Creatine biosynthesis with a Log2 Fold Change overlay

Display only
the compounds
identified by a

confirmatory
spectral match

You can filter the Compounds table to reduce the number of compounds displayed. The processing 
workflow contained the Mark Background Compounds node, so the background compounds that the 
analysis detected are already hidden. 

To display only the compounds that were identified by the mzCloud search

1. Return the result file to its default layout by choosing Window > Reset Layout in the application 
menu bar.

The main Compounds table is the active result table.
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2. In the application menu bar, choose View > Result Filters.

The Result Filters view opens. The right pane is set to the Compounds table.

Figure 23. Result Filters view for the Compounds table

3. Set up the following filter: Annotation Source has status Full Match in source mzCloud Search as 
follows:

a. Click Add Property and select Annot Source from the dropdown list.

b. Click Has Any Value and select Has Status from the dropdown list.

c. Click the green box to the right of Has Status and select Full Match from the dropdown list.

d. Click the green box to the right of In Source and select mzCloud Search from the dropdown list.

4. Click Apply, and then close the Result Filters dialog box.

The number of visible compounds in the Compounds table has been reduced from 4199 to 139.

5. Click the BioCyc Pathways tab in the set of main tables.

6. From the application menu bar, choose View > BioCyc Pathways.

The BioCyc Pathways view appears to the left of the main tables.
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7. In the Omics-Overlay dropdown list, select Log2 Fold Change.

8. In the BioCyc Pathways table, select the Purine and Pyrimidine Metabolism pathway.

Now only the compounds that the analysis identified by searching the mzCloud mass spectral 
database are highlighted in the pathways, as indicated by the color-coded circles. 

Figure 24. Matched compounds in the filtered main Compounds table
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9. Compare the number of highlighted (color-coded circle) compounds in Figure 24 on page 27 to the 
number of highlighted compounds in Figure 18 on page 22.

You have completed the BioCyc tutorial for the Compound Discoverer 3.3 SP2 application. 

Using the
BioCyc

Pathway
Mapping

feature in
Compound
Discoverer

3.3 SP1

If you are using the Compound Discoverer 3.3 SP1 application, you must download and install a 
configuration file to use the Map to BioCyc Pathways node. 

Follow these topics:

1. Download the configuration file and the example files

2. Install the BioCyc service configuration file

Download the
configuration

file and the
example files

To download and install the required configuration file and the Compound Discoverer 3.3.1 
example files

1. Go to the following URL: thermo.flexnetoperations.com

The LSMS Software Download and Licensing Portal website opens.

2. Log in.

3. Under Software & Services at the left, click the Product List link.

4. On the Product List page, click the Application - Compound Discoverer link.

5. On the Product Information page, click the Compound Discoverer 3.3 SP1 link. 

The Product Download page for the Compound Discoverer 3.3 SP1 application opens. This page 
contains BioCycService.config file and the compressed folders with the files for the tutorials provided 
with the application.

Table 1. Comparison of the matched compounds found in the Compounds table before and after filtering out 

compounds that were not identified by the mzCloud search

Filtered by background compounds 
(4199 visible compounds)

Filtered by mzCloud identification and background compounds 
(139 visible compounds)

uridine –
uracil uracil
uridine-5’-phosphate –
cytidine cytidine
thymine thymine
thymidine –
dUMP –
adenosine adenosine
adenine –
AMP AMP
guanosine –
quanine –
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Figure 25. Product Download page for the Compound Discoverer 3.3 SP1 application

6. Download the following items:

• In the File Name column, click  to the left of BioCycService.config.

The BioCyc service configuration file downloads to the Downloads folder on your data 
processing computer.

• If you do not have the example ZDF study folder, click to the left of the CD 3.3 SP1 Example 
Metabolomics Study.ZDF.

The items download to the Downloads folder on your data processing computer. For information 
about the items in the CD 3.3 SP1 Example Metabolomics Study.ZDF and where to store them on 
your data processing computer, see “Locate the ZDF example files” on page 2.

Install the
BioCyc service

configuration
file

After you download the BioCycService.config file, you must copy it to the appropriate folder on your data 
processing computer.

To install the BioCyc service configuration file

1. Close the Compound Discoverer 3.3 SP1 application, if it is open.

2. On your data processing computer, navigate to the following folder:

C:\Program Files\Thermo\Compound Discoverer 3.3\bin\Config

3. Rename the BioCycService.config file to BioCycService.config.bak.

4. Copy the BioCycService.config file from the Downloads folder to the Config folder.

5. Restart the Compound Discoverer 3.3 SP1 application.

After you install the configuration file, you are ready to begin this tutorial at “Copy the ZDF example files 
to your data processing computer” on page 3.

The software you are about to download is subject to export control laws and regulations. By downloading this software, you agree that 
you will not knowingly, without prior written authorization from the competent government authorities, export or reexport - directly or 
indirectly - any software downloaded from this website to any prohibited destination, end-user, or end-use.

Product Download

Compound Discoverer 3.3 SP1

Compound Discoverer 3.3 SP1 Free Upgrade Installation 
Instructions

CD 3.3 SP1 Example Data Metabolomics Study-ZDF.zip

CD 3.3 SP1 Example Data Stable Isotope Labeling 
Study.zip

CD 3.3 SP1 Example GC Studies.zip

Compound Discoverer 3.3 SP1.zip

Compound Discoverer 3.3 SP1 Free Upgrade Installation 
lnstructions.pdf

Compound Discoverer 3.3 SP1 Release Notes.pdf

345 bytes

3.3 GB

2 GB

3 GB

5.7 GB

808.8 KB

1.1 MB

Download Selected Files

7 Files

eziS eliFnoitpircseD eliF

Download Help

File Name

BioCycService

CD 3.3 SP1 Example Data Metabolomics Study-ZDF

CD 3.3 SP1 Example Data Stable Isotope Labeling Study

CD 3.3 SP1 Example GC Studies 

Compound Discoverer 3.3 SP1 Release Notes

Compound Discoverer 3.3 SP1

?
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Trademarks Compound Discoverer, mzCloud, Thermo Scientific, and Xcalibur are trademarks of Thermo Fisher 
Scientific Inc. 

Microsoft, Windows, and Excel are registered trademarks of Microsoft Corporation in the United States 
and other countries.

ChemSpider is a trademark of Chem Zoo Inc.

All other trademarks are the property of Thermo Fisher Scientific Inc. and its subsidiaries. 
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